summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-05 11:46:43 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-05 11:46:43 +0200
commit8d809247621427d66451a400461078179071e52e (patch)
treee270d8b9dfc0f167d0c808b129e55bca140188f4 /Cargo.toml
parent4c4c637f7467bf60eea2d283edaf438ead5fcc31 (diff)
Implement IPFS backend
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6e866a8..b924dd5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,3 +16,12 @@ homepage = "http://github.com/matthiasbeyer/distrox"
edition = "2018"
[dependencies]
+# TODO: Replace with thiserror
+anyhow = "1"
+
+async-trait = "0.1"
+cid = "0.6"
+daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
+ipfs-embed = "0.19"
+libipld = "0.11"
+tokio = { version = "1", features = ["full"] }