summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-05 12:57:56 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-05 13:00:27 +0200
commit8b92314dc0e2398c4a8750bbb66ee1804e64377f (patch)
tree6b2aefa0adf96643e35bb4c4da3af3c4954cd551 /Cargo.toml
parent75a82d3c2eaf1716a057bd5869f7b996965075b7 (diff)
Add Payload type
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 10 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b924dd5..f24ae6f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,9 +19,13 @@ edition = "2018"
# TODO: Replace with thiserror
anyhow = "1"
-async-trait = "0.1"
-cid = "0.6"
-daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
-ipfs-embed = "0.19"
-libipld = "0.11"
-tokio = { version = "1", features = ["full"] }
+async-trait = "0.1"
+cid = "0.6"
+chrono = "0.4"
+daglib = { git = "https://git.sr.ht/~matthiasbeyer/daglib", branch = "master" }
+ipfs-embed = "0.19"
+libipld = "0.11"
+libipld-cbor = "0.11"
+mime = "0.3"
+tokio = { version = "1", features = ["full"] }
+