summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-12-02 19:57:16 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-12-08 18:43:34 +0100
commit36dc8675f5757c81d3b78da19d6f7bb4f34a555c (patch)
tree5bd5a417fce1ab40198f72663ffb6ecaec8047a0 /Cargo.toml
parent969de98ddad7311fbcd74f93910444af8fdb7882 (diff)
Implement hello-world gui with iced
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6766fe6..1760305 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -39,10 +39,16 @@ libp2p = "0.39.1"
tracing = "0.1"
ctrlc = "3.2"
+iced_native = "0.4.0"
+iced_wgpu = "0.4.0"
+
[dependencies.ipfs]
git = "https://github.com/rs-ipfs/rust-ipfs/"
rev = "ad3ab49b4d9236363969b0f74f14aabc7c906b3b"
+[dependencies.iced]
+version = "0.3.0"
+features = ["glow", "tokio", "debug"]
[dev-dependencies]
multibase = "0.8"