summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-12-20 00:01:31 +0100
committerMatthias Beyer <mail@beyermatthias.de>2018-10-07 10:14:33 +0200
commit15bc0ad9c1515e8f326e01ca903c0d88bb787aee (patch)
tree17973661361745da860664e3893b99f70c1af097 /Cargo.toml
Initial import of distrox code
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9e3371c
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "distrox"
+version = "0.1.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+
+description = "Distributed network build on IPFS"
+
+keywords = ["social", "network", "ipfs", "distributed"]
+readme = "README.md"
+license = "GPL-2.0"
+
+documentation = "https://docs.rs/distrox"
+repository = "https://github.com/matthiasbeyer/distrox"
+homepage = "http://github.com/matthiasbeyer/distrox"
+
+[dependencies]
+is-match = "0.1"
+failure = "0.1"
+futures = "0.1"
+ipfs-api = "0.5.0-alpha2"
+serde = "1"
+serde_derive = "1"
+serde_json = "1"
+mime = "0.3"
+chrono = { version = "0.4", features = ["serde"] }
+uuid = { version = "0.7", features = ["serde", "v4"] }
+clap = "2"
+log = "0.4"
+env_logger = "0.5"
+config = "0.9"
+toml = "0.4"
+hyper = "0.12"