summaryrefslogtreecommitdiffstats
path: root/vendored_parsers/tree-sitter-cmake/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendored_parsers/tree-sitter-cmake/pyproject.toml')
-rw-r--r--vendored_parsers/tree-sitter-cmake/pyproject.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/vendored_parsers/tree-sitter-cmake/pyproject.toml b/vendored_parsers/tree-sitter-cmake/pyproject.toml
new file mode 100644
index 000000000..3a449c749
--- /dev/null
+++ b/vendored_parsers/tree-sitter-cmake/pyproject.toml
@@ -0,0 +1,29 @@
+[build-system]
+requires = ["setuptools>=42", "wheel"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "tree-sitter-cmake"
+description = "Cmake grammar for tree-sitter"
+version = "0.0.1"
+keywords = ["incremental", "parsing", "tree-sitter", "cmake"]
+classifiers = [
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Topic :: Software Development :: Compilers",
+ "Topic :: Text Processing :: Linguistic",
+ "Typing :: Typed"
+]
+requires-python = ">=3.8"
+license.text = "MIT"
+readme = "README.md"
+
+[project.urls]
+Homepage = "https://github.com/tree-sitter/tree-sitter-cmake"
+
+[project.optional-dependencies]
+core = ["tree-sitter~=0.21"]
+
+[tool.cibuildwheel]
+build = "cp38-*"
+build-frontend = "build"