summaryrefslogtreecommitdiffstats
path: root/front_end/Cargo.toml
diff options
context:
space:
mode:
authorKornel <kornel@geekhood.net>2019-01-19 23:59:12 +0000
committerKornel <kornel@geekhood.net>2019-01-19 23:59:12 +0000
commit4fba020aa83e6a85d2304f8cc2b9f4ab0af98c4e (patch)
tree4f2aa4c02acc02c904553a210534c61395ec2ec3 /front_end/Cargo.toml
parent1f3caab3d1f856a674318e77b02a9147eb0c8400 (diff)
Subdir
Diffstat (limited to 'front_end/Cargo.toml')
-rw-r--r--front_end/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/front_end/Cargo.toml b/front_end/Cargo.toml
new file mode 100644
index 0000000..fa3ce8d
--- /dev/null
+++ b/front_end/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+edition = "2018"
+name = "front_end"
+version = "0.3.1"
+authors = ["Kornel <kornel@geekhood.net>"]
+autobins = true
+
+[lib]
+name = "front_end"
+path = "src/front_end.rs"
+
+[build-dependencies]
+ructe = "0.5.6"
+
+[dependencies]
+kitchen_sink = { path = "../kitchen_sink", version = "0.7.0" }
+rich_crate = { path = "../rich_crate" }
+render_readme = { git = "https://gitlab.com/crates.rs/render_readme.git", version = "0.5.0" }
+categories = { path = "../categories" }
+udedokei = { git = "https://gitlab.com/crates.rs/udedokei.git" }
+search_index = { path = "../search_index" }
+rayon = "1.0.3"
+failure = "0.1.2"
+chrono = "0.4.2"
+semver = "0.9.0"
+semver-parser = "0.9.0"
+lab = "0.6.0"
+urlencoding = "1.0.0"
+regex = "1.0.0"
+locale = "0.2.2"
+url = "1.7.1"