summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKornel <kornel@geekhood.net>2018-06-23 00:26:28 +0100
committerKornel <kornel@geekhood.net>2018-06-23 14:23:47 +0100
commit19187686a06c18d57f94c867fc91e1113a6e2ec2 (patch)
tree0d650e0c5ee51fa5500657e22cb5f0930a790497 /Cargo.toml
Release of crates.rs!
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..e75b0bb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,75 @@
+
+[workspace]
+members = [
+"cargo_author",
+"cargo_toml",
+"categories",
+"crate_db",
+"crate_files",
+"crates_io_client",
+"docs_rs_client",
+"front_end",
+"github_info",
+"kitchen_sink",
+"lazyonce",
+"reindex",
+"render_readme",
+"repo_url",
+"rich_crate",
+"simple_cache",
+"user_db",
+]
+
+[profile.dev]
+opt-level = 1
+
+[patch.'https://gitlab.com/crates.rs/cargo_author.git']
+cargo_author = { path = "cargo_author" }
+
+[patch.'https://gitlab.com/crates.rs/cargo_toml.git']
+cargo_toml = { path = "cargo_toml" }
+
+[patch.'https://gitlab.com/crates.rs/categories.git']
+categories = { path = "categories" }
+
+[patch.'https://gitlab.com/crates.rs/crate_db.git']
+crate_db = { path = "crate_db" }
+
+[patch.'https://gitlab.com/crates.rs/crate_files.git']
+crate_files = { path = "crate_files" }
+
+[patch.'https://gitlab.com/crates.rs/crates_io_client.git']
+crates_io_client = { path = "crates_io_client" }
+
+[patch.'https://gitlab.com/crates.rs/docs_rs_client.git']
+docs_rs_client = { path = "docs_rs_client" }
+
+[patch.'https://gitlab.com/crates.rs/front_end.git']
+front_end = { path = "front_end" }
+
+[patch.'https://gitlab.com/crates.rs/github_info.git']
+github_info = { path = "github_info" }
+
+[patch.'https://gitlab.com/crates.rs/kitchen_sink.git']
+kitchen_sink = { path = "kitchen_sink" }
+
+[patch.'https://gitlab.com/crates.rs/lazyonce.git']
+lazyonce = { path = "lazyonce" }
+
+[patch.'https://gitlab.com/crates.rs/reindex.git']
+reindex = { path = "reindex" }
+
+[patch.'https://gitlab.com/crates.rs/render_readme.git']
+render_readme = { path = "render_readme" }
+
+[patch.'https://gitlab.com/crates.rs/repo_url.git']
+repo_url = { path = "repo_url" }
+
+[patch.'https://gitlab.com/crates.rs/rich_crate.git']
+rich_crate = { path = "rich_crate" }
+
+[patch.'https://gitlab.com/crates.rs/simple_cache.git']
+simple_cache = { path = "simple_cache" }
+
+[patch.'https://gitlab.com/crates.rs/user_db.git']
+user_db = { path = "user_db" }