summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Orchard <if_coding@fastmail.com>2021-07-28 23:49:31 -0700
committerDavid Orchard <if_coding@fastmail.com>2021-08-15 10:31:28 -0700
commitf14adeb0984f81883cd85c6590c960f4dcadb59b (patch)
tree1f752562a47f988a23768ca957d18849380480f0 /Cargo.toml
parentfc8cf0ed674cbb495df1baff34d4b832ca5fad3c (diff)
Enable dependency features for map order preservation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 68e6617..3c2e622 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,12 +28,12 @@ lazy_static = "1.0"
serde = "1.0.8"
nom = "6"
-toml = { version = "0.5", optional = true }
-serde_json = { version = "1.0.2", optional = true }
+toml = { version = "0.5", features = ["preserve_order"], optional = true }
+serde_json = { version = "1.0.2", features = ["std", "preserve_order"], optional = true }
yaml-rust = { version = "0.4", optional = true }
serde-hjson = { version = "0.9", default-features = false, optional = true }
rust-ini = { version = "0.17", optional = true }
-ron = { version = "0.6", optional = true }
+ron = { version = "0.6", features = ["indexmap"], optional = true }
json5_rs = { version = "0.3", optional = true, package = "json5" }
linked-hash-map = { version = "0.5.4", features = ["serde_impl"] }