summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Orchard <if_coding@fastmail.com>2021-08-01 00:11:40 -0700
committerDavid Orchard <if_coding@fastmail.com>2021-08-15 10:32:07 -0700
commitea62693f6fff0dd24865b934334260d06f190e01 (patch)
tree7a071eea0dcb2630bd8ca018fdffca350e8adeac /Cargo.toml
parentcc0530a7716779f954b1756905a9f4ceb7eb6d62 (diff)
Switch from LinkedHashMap to IndexMap
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8d76ba0..d530d06 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,7 +21,7 @@ yaml = ["yaml-rust"]
hjson = ["serde-hjson"]
ini = ["rust-ini"]
json5 = ["json5_rs"]
-preserve_order = ["linked-hash-map", "toml/preserve_order", "serde_json/preserve_order", "ron/indexmap"]
+preserve_order = ["indexmap", "toml/preserve_order", "serde_json/preserve_order", "ron/indexmap"]
[dependencies]
async-trait = "0.1.50"
@@ -36,7 +36,7 @@ serde-hjson = { version = "0.9", default-features = false, optional = true }
rust-ini = { version = "0.17", optional = true }
ron = { version = "0.6", optional = true }
json5_rs = { version = "0.3", optional = true, package = "json5" }
-linked-hash-map = { version = "0.5.4", optional = true, features = ["serde_impl"] }
+indexmap = { version = "1.7.0", features = ["serde-1"], optional = true}
[dev-dependencies]
serde_derive = "1.0.8"