summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorup9cloud <8325632+up9cloud@users.noreply.github.com>2020-07-06 13:07:05 -0700
committerMatthias Beyer <mail@beyermatthias.de>2021-05-15 14:35:58 +0200
commit70c503af8b3cb3d73bbbea673bb49460df318e5e (patch)
tree3550f1015af6186e5f6c1cade83345ee48609e22 /Cargo.toml
parent266f504d9f23e192c03ef486f58a678847249b60 (diff)
Support format json5
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca28c06..929f7ff 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,11 +15,12 @@ edition = "2018"
maintenance = { status = "actively-developed" }
[features]
-default = ["toml", "json", "yaml", "hjson", "ini", "ron"]
+default = ["toml", "json", "yaml", "hjson", "ini", "ron", "json5"]
json = ["serde_json"]
yaml = ["yaml-rust"]
hjson = ["serde-hjson"]
ini = ["rust-ini"]
+json5 = ["json5_rs", "serde_derive"]
[dependencies]
lazy_static = "1.0"
@@ -32,6 +33,8 @@ yaml-rust = { version = "0.4", optional = true }
serde-hjson = { version = "0.9", default-features = false, optional = true }
rust-ini = { version = "0.17", optional = true }
ron = { version = "0.6", optional = true }
+json5_rs = { version = "0.3", optional = true, package = "json5" }
+serde_derive = { version = "1.0.8", optional = true }
[dev-dependencies]
serde_derive = "1.0.8"