summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 9 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 98a1383..a970a89 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,17 +1,19 @@
[package]
-name = "config"
+name = "config-maint"
version = "0.10.1"
-description = "Layered configuration system for Rust applications."
-homepage = "https://github.com/mehcode/config-rs"
-repository = "https://github.com/mehcode/config-rs"
+description = "Layered configuration system for Rust applications. (Maintenance fork)"
+homepage = "https://sr.ht/~matthiasbeyer/config-rs-maint/"
+repository = "https://git.sr.ht/~matthiasbeyer/config-rs-maint/"
+documentation = "https://docs.rs/config-maint"
readme = "README.md"
keywords = ["config", "configuration", "settings", "env", "environment"]
-authors = ["Ryan Leckey <leckey.ryan@gmail.com>"]
+authors = ["Ryan Leckey <leckey.ryan@gmail.com>",
+ "Matthias Beyer <mail@beyermatthias.de>"]
categories = ["config"]
license = "MIT/Apache-2.0"
[badges]
-travis-ci = { repository = "mehcode/config-rs" }
+maintenance = { status = "actively-developed" }
[features]
default = ["toml", "json", "yaml", "hjson", "ini"]
@@ -28,7 +30,7 @@ nom = "5.0.0"
toml = { version = "0.5", optional = true }
serde_json = { version = "1.0.2", optional = true }
yaml-rust = { version = "0.4", optional = true }
-serde-hjson = { version = "0.9", optional = true }
+serde-hjson = { version = "0.9", default-features = false, optional = true }
rust-ini = { version = "0.13", optional = true }
[dev-dependencies]