summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorsaber.wu <saber.wu@trantect.com>2018-06-14 17:09:43 +0800
committersaber.wu <saber.wu@trantect.com>2018-06-15 11:13:53 +0800
commitba6014543dfb4040921bb4809c6b293cfdf33c84 (patch)
tree523708c74eb31e5c861c7e474f092fafbd416879 /Cargo.toml
parente8fa9fee96185ddd18ebcef8a925c75459111edb (diff)
support ini
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8ee4d4c..8a33e4d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,10 +14,12 @@ license = "MIT/Apache-2.0"
travis-ci = { repository = "mehcode/config-rs" }
[features]
-default = ["toml", "json", "yaml", "hjson"]
+default = ["toml", "json", "yaml", "hjson","ini"]
json = ["serde_json"]
yaml = ["yaml-rust"]
hjson = ["serde-hjson"]
+ini = []
+
[dependencies]
lazy_static = "1.0"
@@ -28,6 +30,7 @@ toml = { version = "^0.4.1", optional = true }
serde_json = { version = "^1.0.2", optional = true }
yaml-rust = { version = "^0.4", optional = true }
serde-hjson = { version = "^0.8.1", optional = true }
+rust-ini = "0.12.1"
[dev-dependencies]
serde_derive = "^1.0.8"