summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRaphael Cohn <raphael.cohn@stormmq.com>2017-09-01 09:06:27 +0100
committerRaphael Cohn <raphael.cohn@stormmq.com>2017-09-01 09:06:27 +0100
commit9826b2cda730116e148120dafe0fa89bd389626e (patch)
tree164597d8e40017ca690c259c75eacee9134f6f5d /Cargo.toml
parent13151213a7b368296c616e0a770fb2c238fff1a0 (diff)
Added HJSON (Human-Readable JSON) as a config file format
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1317a27..c3789ab 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,9 +14,10 @@ license = "MIT/Apache-2.0"
travis-ci = { repository = "mehcode/config-rs" }
[features]
-default = ["toml", "json", "yaml"]
+default = ["toml", "json", "yaml", "hjson"]
json = ["serde_json"]
yaml = ["yaml-rust"]
+hjson = ["serde-hjson"]
[dependencies]
lazy_static = "0.2"
@@ -26,6 +27,7 @@ nom = "^3.0.0"
toml = { version = "^0.4.1", optional = true }
serde_json = { version = "^1.0.2", optional = true }
yaml-rust = { version = "^0.3.5", optional = true }
+serde-hjson = { version = "^0.8.1", optional = true }
[dev-dependencies]
serde_derive = "^1.0.8"