summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-09-27 22:50:31 +0200
committerMatthias Beyer <matthias.beyer@atos.net>2020-10-12 15:14:17 +0200
commitb542789c87e2acdc1de3d52bd0670ace325a87d3 (patch)
tree13e3817c59f1db797b71f8c13c07a4a826c6b651 /shell.nix
Initial import
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..341c15b
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,33 @@
+{ ... }:
+
+let
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+in
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
+
+ cmake
+ curl
+ gcc
+ openssl
+ pkgconfig
+ which
+ zlib
+ ];
+
+ shellHook = ''
+ alias docker='docker --host=tcp://localhost:8095'
+ '';
+
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+}
+
+