summaryrefslogtreecommitdiffstats
path: root/examples/packages/Makefile
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-02-10 19:14:55 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-02-11 18:22:38 +0100
commitc2fb88e4ea953d4dbc01ffc6341ccb4e9e59290c (patch)
tree8b6d21dd6a91a6e014beecb58bff32cd08542d06 /examples/packages/Makefile
parentf1eca4972dafc3e5eeb63a1efd65f76d2d7c6ed4 (diff)
Remove simple examples, add complex one
This patch removes the many simple examples and replaces them with one big example repository with 26 packages that have a complex dependency setup. This is nice for testing. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'examples/packages/Makefile')
-rw-r--r--examples/packages/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/examples/packages/Makefile b/examples/packages/Makefile
new file mode 100644
index 0000000..eca35f8
--- /dev/null
+++ b/examples/packages/Makefile
@@ -0,0 +1,34 @@
+export BUTIDO_RELEASES="/tmp/butido-test-releases"
+export BUTIDO_STAGING="/tmp/butido-test-staging"
+export BUTIDO_SOURCE_CACHE="/tmp/butido-test-sources"
+export BUTIDO_LOG_DIR="/tmp/butido-test-logs"
+export BUTIDO_REPO="/tmp/butido-test-repo"
+
+.PHONY: all
+all: directories copyrepo copysrc
+
+directories: ${BUTIDO_RELEASES} ${BUTIDO_STAGING} ${BUTIDO_SOURCE_CACHE} ${BUTIDO_LOG_DIR} ${BUTIDO_REPO}
+
+copyrepo: ${BUTIDO_REPO}
+ cp -rv ./repo/* ${BUTIDO_REPO}/
+ cd ${BUTIDO_REPO}/ && git init && git add . && git commit -m init
+
+copysrc: ${BUTIDO_SOURCE_CACHE}
+ cp -rv ./sources/* ${BUTIDO_SOURCE_CACHE}/
+
+${BUTIDO_RELEASES}:
+ mkdir -p "${BUTIDO_RELEASES}"
+
+${BUTIDO_STAGING}:
+ mkdir -p "${BUTIDO_STAGING}"
+
+${BUTIDO_SOURCE_CACHE}:
+ mkdir -p "${BUTIDO_SOURCE_CACHE}"
+
+${BUTIDO_LOG_DIR}:
+ mkdir -p "${BUTIDO_LOG_DIR}"
+
+${BUTIDO_REPO}:
+ mkdir -p "${BUTIDO_REPO}"
+
+