summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-01-13 21:30:57 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-01-15 23:17:39 +0100
commitf330587fec0cdf2f041531d5e7aea1e4f525e11b (patch)
tree8a2c92466fe8156ac5f54c6871fea271e768e55d /Cargo.toml
parent4cf5a22ad1b0f5bf8f4e2c06c689ad40230e4387 (diff)
Reimplement tree printing using 'ptree'
This patch reimplements the tree-printing using the 'ptree' crate. Because ptree wants the tree item to implement `Clone`, a wrapper type is added which then implements `Clone` and `ptree::TreeItem` Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 38157d2..d89f99f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,6 +34,7 @@ lazy_static = "1.4"
log = "0.4"
parse-display = "0.4"
pom = "3"
+ptree = "0.3"
regex = "1"
reqwest = { version = "0.10", features = [ "stream" ] }
resiter = "0.4"