summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-01-30 15:18:53 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-01-30 15:18:53 +0100
commita91435fe5c043402df9c3ddeba114fb424fce1bc (patch)
tree6030f0a711f46bc9e05a4bc8642001015de4fe1d /Cargo.toml
parent6c719e76a08a3cf27fc7caa6479427561d3c35ed (diff)
Update tokio: 0.2 -> 1.0, shiplift
Because tokio 1.0 does not ship with the Stream trait, this patch also introduces tokio_stream as new dependency. For more information, look here: https://docs.rs/tokio/1.0.3/tokio/stream/index.html Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4147250..b2dc1dc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,11 +45,12 @@ serde = "1"
serde_json = "1"
sha1 = { version = "0.6", features = ["std"] }
sha2 = "0.9"
-shiplift = { git = "https://github.com/softprops/shiplift", rev = "03cc8c075f86f1bd9e2c4e29872a0e8b9072c7f0" }
+shiplift = { git = "https://github.com/softprops/shiplift", rev = "f5017f603afab9821966032ea652cb3161051f17" }
syntect = "4.4"
tar = "0.4"
terminal_size = "0.1"
-tokio = { version = "0.2", features = ["macros", "fs", "process", "io-util", "blocking"] }
+tokio = { version = "1.0", features = ["macros", "fs", "process", "io-util"] }
+tokio-stream = "0.1"
typed-builder = "0.8"
unindent = "0.1"
url = { version = "2", features = ["serde"] }