summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-10-19 08:26:15 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-10-19 08:41:13 +0200
commita73b2d0d04fddbfe69e0872b6856b112ebec6d71 (patch)
tree0dea4ee6d6c40c0f36ef4245b94f36aff4dd2d0c /Cargo.toml
parent5b99282ba23e1002a576934a371c8b9fe7755963 (diff)
Replace "ptree" with maintenance fork
Because ptree 0.3.2 dependends on crates that have security advisories (down the dependency chain), we depend on a fork of ptree now, which updates these dependencies. We hope that this resolves the advisories for us. This patch shall be reverted as soon as ptree 0.4.0 (with updated dependencies) is published. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7054b2d..ce4a82a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -51,7 +51,7 @@ lazy_static = "1.4"
log = "0.4"
parse-display = "0.5"
pom = "3"
-ptree = "0.3"
+ptree = { git = "https://github.com/matthiasbeyer/ptree", branch = "maint" }
rayon = "1.5"
regex = "1"
reqwest = { version = "0.11", features = [ "stream" ] }