summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@atos.net>2021-08-31 10:07:00 +0200
committerMatthias Beyer <matthias.beyer@atos.net>2021-08-31 10:07:00 +0200
commit910af91c2eb5d58b9fdf0317ba086c4ed687d690 (patch)
tree91024217a866e3ef1b98273814dc96e270a598c2 /Cargo.toml
parent11437e5eefa79e419ed52c6b699eb3e5b3a553fa (diff)
Pin dependency clap
Because we didn't pin the dependency in Cargo.toml, a `cargo update` or fresh build resulted in beta.4 being used and fails because a new feature was introduced in newer compilers. Hence, pin the clap version to exactly this version for now. Signed-off-by: Matthias Beyer <matthias.beyer@atos.net>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f70a9e0..71ff5e6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,8 +27,8 @@ ascii_table = ">= 3.0.2"
atty = "0.2"
bytesize = "1"
chrono = "0.4"
-clap = "3.0.0-beta.2"
-clap_generate = "3.0.0-beta.2"
+clap = "=3.0.0-beta.2"
+clap_generate = "=3.0.0-beta.2"
colored = "2"
config = { version = "0.11", default-features = false, features = [ "toml" ] }
csv = "1.1"