summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-11-15 11:35:32 +0100
committerMatthias Beyer <mail@beyermatthias.de>2020-11-15 11:39:34 +0100
commit771f957d4202bfa15820dc004b9cb874a32b7746 (patch)
tree302b918379b0a8289921d55ef431bef37279d6d9 /Cargo.toml
parent183eac77bfd87eb5c2d8e2832d3fe35779ec5fef (diff)
Implement error reporting of failed jobs
This patch implements error reporting if a container job did not end successfully. It does so by adding an error type `ContainerError`, which is either an error that describes that a container did not exit with success, or an anyhow::Error (that describes an error from the container management code). The algorithm of log-aggregation is now intercepted to catch any exit-state log items. If there is no exit-state from the container (No line with "#BUTIDO:STATE:..."), no error is assumed. Here could be a warning later on. The so aggregated state is then passed up to the orchestrator, which then collects the errors and prints them. If the implementation is correct (which is not tested yet, because this is rather difficult to test), all other containers should continue operation until they are ready, before the errors are handled. The code responsible for this (in the Orchestrator implementation) was adapted to not collect until the first error, but collect everything and then check for errors. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 41637b6..7beacb5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,6 +45,7 @@ sha2 = "0.9"
reqwest = { version = "0.10", features = [ "stream" ] }
colored = "2"
syntect = "4.4"
+thiserror = "1"
url = { version = "2", features = ["serde"] }
tokio = { version = "0.2", features = ["full"] }