summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-12-03 08:15:56 +0100
committerMatthias Beyer <mail@beyermatthias.de>2020-12-03 08:15:56 +0100
commit6bcc9af36a900a897aa041deb96d9c3330fe40b2 (patch)
tree70fc2a6a7f55a6f7f4cdc2c7ce3bc007fdc6642e /Cargo.toml
parentba2f301e946ee9192229ff67ac9cb6dc90e162d2 (diff)
Update dependency: ascii_table must be 3.0.2 or newer
This patch updates the ascii_table dependency with a requirement to be 3.0.2 or newer. This is because ascii_table was licensed as GPLv3 before that version, and got relicensed to MIT in 3.0.2. Because we do not want to depend on a library that is GPLv3, we asked the author to relicense their crate, which is what they did for us. This patch thus ensures that we do not link GPLv3 code. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 146fd38..1babec6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,7 +33,7 @@ typed-builder = "0.7"
tar = "0.4"
diesel = { version = "1.4", features = ["postgres", "chrono", "uuid", "serde_json"] }
which = "4"
-ascii_table = "3"
+ascii_table = ">= 3.0.2"
terminal_size = "0.1"
atty = "0.2"
csv = "1.1"