summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@atos.net>2021-03-09 19:12:39 +0100
committerMatthias Beyer <matthias.beyer@atos.net>2021-03-10 11:10:22 +0100
commit23489e5e9a39e6dbf0cdd4e81c9a5c273905bdfd (patch)
treeae78b7d8c49f9241cdc2b80b0cc0974bd3aafa9e /Cargo.toml
parent0d0ece897986e0e5960a047a20d51dc58f0483b5 (diff)
Re-write patch postprocessing
This patch rewrites patch post-processing with a new setter in the config-rs crate: Config::set_once() That is introduced on a PR I've written for the crate. The PR: https://github.com/mehcode/config-rs/pull/172 The new function is more likely to land on the config-rs master branch than the old one, as it does not introduce more exported types from the config-rs crate. Signed-off-by: Matthias Beyer <matthias.beyer@atos.net> Tested-by: Matthias Beyer <matthias.beyer@atos.net>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ba5f57f..bcd7346 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ chrono = "0.4"
clap = "3.0.0-beta.2"
clap_generate = "3.0.0-beta.2"
colored = "2"
-config = { git = "https://github.com/matthiasbeyer/config-rs", branch = "get-value-mut" }
+config = { git = "https://github.com/matthiasbeyer/config-rs", branch = "add-setter" }
csv = "1.1"
daggy = { version = "0.7", features = [ "serde" ] }
dialoguer = "0.7"