summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-02-19 09:09:23 +0100
committerMatthias Beyer <matthias.beyer@atos.net>2021-03-09 19:17:09 +0100
commit0a2ec1ec96832e798dfd376d996c0604cb38439f (patch)
tree8df7be296663008584b4c43c2408a09f9475a264 /Cargo.toml
parent60a3fa633a33e315c1439a9f2436fcdb48da62ae (diff)
Implement patch-path rewriting
This patch ensures that pathes for patches are always relative to the repository root, when loading the packages layered from the repository. The problem is well described in the comment in the code, so this commit message ends here. This patch was written using an proposed feature for the config-rs dependency: https://github.com/mehcode/config-rs/pull/165 This PR added a `Config::get_value_mut()` function and exported the `config::value::ValueKind` type in config-rs public API. Signed-off-by: Matthias Beyer <matthias.beyer@atos.net> Tested-by: Matthias Beyer <matthias.beyer@atos.net>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2ca07fe..ba5f57f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ chrono = "0.4"
clap = "3.0.0-beta.2"
clap_generate = "3.0.0-beta.2"
colored = "2"
-config = "0.10"
+config = { git = "https://github.com/matthiasbeyer/config-rs", branch = "get-value-mut" }
csv = "1.1"
daggy = { version = "0.7", features = [ "serde" ] }
dialoguer = "0.7"