summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 862b66e..44ae888 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,8 +44,14 @@ if(BTOP_STATIC)
endif()
include(CheckCXXCompilerFlag)
+include(CheckIncludeFileCXX)
include(CheckIPOSupported)
+check_include_file_cxx(ranges CXX_HAS_RANGES)
+if(NOT CXX_HAS_RANGES)
+ message(FATAL_ERROR "The compiler doesn't support <ranges>")
+endif()
+
add_executable(btop
src/btop.cpp
src/btop_config.cpp