summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCanop <cano.petrole@gmail.com>2022-01-21 22:37:33 +0100
committerCanop <cano.petrole@gmail.com>2022-01-21 22:37:33 +0100
commitd75f7580fd8cd5ce7f2564b555f161ecbfdc1dcf (patch)
tree514f432c484df4f94f40445ea70ca932af74ed3c /Cargo.toml
parentfcaf7b5cff5f038e4583d67cbe26e6f196ef7338 (diff)
Fix a crash on a syntect panic on svelte file
fall back to unstyled when syntect crashes. This uses a temporary fork, which hopefully will disappear as soon as syntect 5 is usable.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0ccf0ba..4ebb6df 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "broot"
-version = "1.9.1"
+version = "1.9.2-dev"
authors = ["dystroy <denys.seguret@gmail.com>"]
repository = "https://github.com/Canop/broot"
documentation = "https://dystroy.org/broot"
@@ -11,7 +11,7 @@ license = "MIT"
categories = ["command-line-utilities"]
readme = "README.md"
build = "build.rs"
-rust-version = "1.56"
+rust-version = "1.58"
exclude = ["website", "broot*.zip"]
[features]
@@ -53,7 +53,8 @@ serde = { version = "1.0", features = ["derive"] }
smallvec = "1.6"
splitty = "0.1"
strict = "0.1.4"
-syntect = "4.6"
+# syntect = "4.6"
+syntect = { git = "https://github.com/Canop/syntect", branch = "version-4.6" }
tempfile = "3.2"
termimad = "0.20.0"
terminal-clipboard = { version = "0.3.1", optional = true }
@@ -107,6 +108,7 @@ harness = false
# minimad = { path = "../minimad" }
# secular = { path = "../secular", features=["normalization"] }
# strict = { path = "../strict" }
+# syntect = { path = "../syntect" }
# termimad = { path = "../termimad" }
# terminal-clipboard = { path = "../terminal-clipboard" }
# umask = { path = "../umask" }