summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCanop <cano.petrole@gmail.com>2022-03-07 17:03:14 +0100
committerCanop <cano.petrole@gmail.com>2022-03-07 17:03:14 +0100
commitc2efd0444ecaba5fd592d7c5b5c5f3b4a61123d6 (patch)
tree99757bc5d0c2c450ac6d6db964b6aae5836699a0 /Cargo.toml
parenta4aac491fcbfaa35eabe4a8ce8666895b7ab94d4 (diff)
don't query size of remote volumes
This prevents a temporary hang when running broot with size option or in filesystem state if a remote volume is unreachable.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ca2d335..b9b6746 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "broot"
-version = "1.9.3"
+version = "1.9.4-dev"
authors = ["dystroy <denys.seguret@gmail.com>"]
repository = "https://github.com/Canop/broot"
documentation = "https://dystroy.org/broot"
@@ -11,7 +11,7 @@ license = "MIT"
categories = ["command-line-utilities"]
readme = "README.md"
build = "build.rs"
-rust-version = "1.58"
+rust-version = "1.59"
exclude = ["website", "broot*.zip"]
[features]
@@ -68,7 +68,7 @@ unicode-width = "0.1.8"
glassbench = "0.3.0"
[target.'cfg(unix)'.dependencies]
-lfs-core = "0.4.2"
+lfs-core = "0.11.0"
users = "0.11"
[target.'cfg(windows)'.dependencies]
@@ -84,6 +84,7 @@ debug = false
debug = false
lto = true
codegen-units = 1 # this removes a few hundred bytes from the final exec size
+strip = true
[[bench]]
name = "fuzzy"