summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCanop <cano.petrole@gmail.com>2021-02-01 14:59:26 +0100
committerCanop <cano.petrole@gmail.com>2021-02-01 14:59:26 +0100
commit7f2246ac48845c12fe14b74e004da7e6d1999c38 (patch)
tree95ce75aece8da7a8bfda877d796801dfd5bfa684 /Cargo.toml
parent46cfd1db5339613d2edf0207c4a0fc77dff01c0c (diff)
fix crash on page-down when last line of text preview is selected
Fix #339
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 10 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 21bcace..dbe1f25 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "broot"
-version = "1.2.1"
+version = "1.2.2-dev"
authors = ["dystroy <denys.seguret@gmail.com>"]
repository = "https://github.com/Canop/broot"
documentation = "https://dystroy.org/broot"
@@ -26,7 +26,7 @@ char_reader = "0.1"
clap = { version="2.33", default-features=false, features=["suggestions"] }
cli-log = "0.1"
chrono = "0.4"
-crossbeam = "0.7"
+crossbeam = "0.8"
crossterm = "0.17.7"
custom_error = "1.6"
deser-hjson = "0.1.7"
@@ -41,12 +41,12 @@ lazy-regex = "0.1.3"
lazy_static = "1.4"
libc = "0.2"
log = "0.4"
-minimad = "=0.6.7"
+minimad = "=0.6.9"
open = "1.4"
memmap = "0.7"
pathdiff = "0.1.0"
phf = { version = "0.8", features = ["macros"] }
-rayon = "1.4"
+rayon = "1.5"
regex = "1.3"
secular = "0.2"
serde = { version = "1.0", features = ["derive"] }
@@ -54,7 +54,7 @@ splitty = "0.1"
strict = "0.1.4"
syntect = "4.2"
tempfile = "3.1"
-termimad = "0.9.2"
+termimad = "0.9.4"
terminal-clipboard = { version = "0.1.1", optional = true }
toml = "0.5"
umask = "1.0"
@@ -74,7 +74,11 @@ is_executable = "0.1"
[build-dependencies]
clap = "2.33"
+[profile.dev]
+debug = false
+
[profile.release]
+debug = false
lto = true # link time optimization - roughly halves the size of the exec
codegen-units = 1 # this removes a few hundred bytes from the final exec size
@@ -92,7 +96,7 @@ harness = false
# minimad = { path = "../minimad" }
# termimad = { path = "../termimad" }
# crossterm = { path = "../crossterm-rs/crossterm" }
-#deser-hjson = { path = "../deser-hjson" }
+# deser-hjson = { path = "../deser-hjson" }
# umask = { path = "../umask" }
# secular = { path = "../secular" }
# strict = { path = "../strict" }