summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCanop <cano.petrole@gmail.com>2021-06-02 13:45:12 +0200
committerCanop <cano.petrole@gmail.com>2021-06-02 13:45:12 +0200
commit77f40f74c38392a5213f99006138d74772ac5c6c (patch)
tree145732e2e45e0dd3bf17e2a2f3e07027cc5d3338 /Cargo.toml
parent7635373786d1c0fbc45c326d4a0a8914396f7051 (diff)
make the number of threads used for file summing configurable
Also replace lazy_static with once_cell
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bcb3a09..20ddeba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -38,10 +38,10 @@ git2 = { version="0.13", default-features=false }
glob = "0.3"
id-arena = "2.2.1"
image = "0.23.14"
-lazy-regex = "2.0.2"
-lazy_static = "1.4"
+lazy-regex = "2.1.0"
libc = "0.2"
-minimad = "0.7.1"
+minimad = "0.8.0"
+once_cell = "1.7"
open = "1.4"
memmap = "0.7"
pathdiff = "0.2"
@@ -55,7 +55,7 @@ splitty = "0.1"
strict = "0.1.4"
syntect = "4.5"
tempfile = "3.2"
-termimad = { version = "0.10.3" }
+termimad = { version = "0.11.0" }
terminal-clipboard = { version = "0.2.1", optional = true }
toml = "0.5"
umask = "1.0"