summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCanop <cano.petrole@gmail.com>2022-01-05 21:27:39 +0100
committerCanop <cano.petrole@gmail.com>2022-01-05 21:27:39 +0100
commit0b15aede22d52d1f3a0fdf74e2e70ce4cd349f29 (patch)
treefb19431dbf24e04c60147a64306c87b7554b6338 /Cargo.toml
parentc6871fef4b9b00a4876fff0e050a7c546372eeba (diff)
images rendered with kitty protocol on wezterm
It's experimental and might be removed as wezterm doesn't seem to support image resizing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 66a59d6..4d1317d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,6 +17,7 @@ exclude = ["website", "broot*.zip"]
[features]
default = []
clipboard = ["terminal-clipboard"]
+kitty-csi-check = ["xterm-query"]
[dependencies]
ahash = { version = "0.7", features = ["serde"] }
@@ -57,6 +58,7 @@ tempfile = "3.2"
termimad = "0.20.0"
terminal-clipboard = { version = "0.3.1", optional = true }
toml = "0.5"
+xterm-query = { version = "0.1", optional = true }
umask = "1.0"
unicode-width = "0.1.8"