summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2020-04-04 18:43:36 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2020-04-04 22:04:45 +0200
commitda6d1ac538827100fc8a546378fb5fd9bca6ca7d (patch)
tree552106fb15fdb9c209e6db2c30a672f8716ba828 /setup.py
parentcf8dac55de186bc92e4a0f8762f902844b390e09 (diff)
support msgpack 1.0.0, fixes #5065
our data structures need strict_map_key=False, which is not the default of msgpack 1.0.0. i made it default in our wrapper API. call our wrapper for performance profile creation/conversion also to avoid msgpack compat issues. remove encoding from wrapper api, we do not use it any more. remove raw is True check, we need false for profiles strict_map_key is only supported for msgpack >= 1.0.0.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8ee14ebf6..52654326c 100644
--- a/setup.py
+++ b/setup.py
@@ -71,7 +71,7 @@ on_rtd = os.environ.get('READTHEDOCS')
install_requires = [
# we are rather picky about msgpack versions, because a good working msgpack is
# very important for borg, see: https://github.com/borgbackup/borg/issues/3753
- 'msgpack >=0.5.6, <=0.6.2',
+ 'msgpack >=0.5.6, <=1.0.0',
# Please note:
# using any other version is not supported by borg development and
# any feedback related to issues caused by this will be ignored.