summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2022-08-04 15:50:05 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2022-08-04 15:50:05 +0200
commit69f4898460668bdcc8e7ff46052717ae3416ee76 (patch)
treedcde3f707a3c40e619c3a94582631b76d0272001 /setup.py
parentb3b5602ac23c1ef8383ce26284a4f86ff9e5aa64 (diff)
make setuptools happy, fixes #6874
work around setuptools puking about: ############################ # Package would be ignored # ############################ Python recognizes 'borg.cache_sync' as an importable package, but it is not listed in the `packages` configuration of setuptools. 'borg.cache_sync' has been automatically added to the distribution only because it may contain data files, but this behavior is likely to change in future versions of setuptools (and therefore is considered deprecated). Please make sure that 'borg.cache_sync' is included as a package by using the `packages` configuration field or the proper discovery methods (for example by using `find_namespace_packages(...)`/`find_namespace:` instead of `find_packages(...)`/`find:`). You can read more about "package discovery" and "data files" on setuptools documentation page.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 95c31fe02..dd42245af 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ except ImportError:
multiprocessing = None
from setuptools.command.build_ext import build_ext
-from setuptools import setup, find_packages, Extension, Command
+from setuptools import setup, find_namespace_packages, Extension, Command
from setuptools.command.sdist import sdist
try:
@@ -292,7 +292,7 @@ setup(
'Topic :: Security :: Cryptography',
'Topic :: System :: Archiving :: Backup',
],
- packages=find_packages('src'),
+ packages=find_namespace_packages('src'),
package_dir={'': 'src'},
zip_safe=False,
entry_points={