summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2022-04-18 05:00:17 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2022-04-18 05:00:17 +0200
commit6ab17ee4e185fbbba85c4d7b19dd2b2111e0f99d (patch)
treeeedab5022e6c6f5c13867790fcd1080bfd5fa1f4 /pyproject.toml
parent70e30dea4d651a50ad318f569af1d64d77d728af (diff)
setuptools_scm: also require it via pyproject.toml
we have this in setup_requires in setup.py, but i also added it to pyproject.toml - so we can be sure it is installed no matter what. **configuration** of setuptools_scm is done the old way in setup.py here in 1.2-maint, in master we have switched that over to pyproject.toml.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index bf25a1028..74a6bc861 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,3 @@
[build-system]
-requires = ["setuptools", "pkgconfig", "Cython"]
+requires = ["setuptools", "pkgconfig", "Cython", "setuptools_scm>=1.7"]
build-backend = "setuptools.build_meta"