summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Nordholts <enselic@gmail.com>2023-10-10 16:54:34 +0200
committerMartin Nordholts <enselic@gmail.com>2023-10-11 19:14:12 +0200
commitfc9546854f5a7b38823f4990453c6cde386bfd3b (patch)
tree2162ed483d2ea45ac71513a9a02e646aac8bf5c0 /Cargo.toml
parent32da58e723791dc6bf75ededc11aa5bee6d56503 (diff)
Bump version to v0.24.0v0.24.0
We need to bump 0.x.0 because the library API changed in incompatible ways: $ cargo public-api diff Resolved `diff` to `diff 0.23.0` Removed items from the public API ================================= (none) Changed items in the public API =============================== -pub fn bat::controller::Controller<'b>::run(&self, inputs: alloc::vec::Vec<bat::input::Input<'_>>) -> bat::error::Result<bool> +pub fn bat::controller::Controller<'b>::run(&self, inputs: alloc::vec::Vec<bat::input::Input<'_>>, output_buffer: core::option::Option<&mut dyn core::fmt::Write>) -> bat::error::Result<bool> -pub fn bat::controller::Controller<'b>::run_with_error_handler(&self, inputs: alloc::vec::Vec<bat::input::Input<'_>>, handle_error: impl core::ops::function::Fn(&bat::error::Error, &mut dyn std::io::Write)) -> bat::error::Result<bool> +pub fn bat::controller::Controller<'b>::run_with_error_handler(&self, inputs: alloc::vec::Vec<bat::input::Input<'_>>, output_buffer: core::option::Option<&mut dyn core::fmt::Write>, handle_error: impl core::ops::function::Fn(&bat::error::Error, &mut dyn std::io::Write)) -> bat::error::Result<bool> Added items to the public API ============================= [...]
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3b38734a..e31fbc31 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,7 +6,7 @@ homepage = "https://github.com/sharkdp/bat"
license = "MIT OR Apache-2.0"
name = "bat"
repository = "https://github.com/sharkdp/bat"
-version = "0.23.0"
+version = "0.24.0"
exclude = ["assets/syntaxes/*", "assets/themes/*"]
build = "build.rs"
edition = '2018'