summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-11-02 23:16:04 +0800
committercyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-12-11 10:20:12 +0800
commit9f7d70f6421082ae325f88eb9533cf3772ce420b (patch)
tree4440cb120f8b16820f433eb40392adbb28e9ad0d /Cargo.toml
parent0fea82cff9da575e4dd297cdbc9c20569b0aa88e (diff)
Use regex for matcher parsing
- Somewhat better maintainability I think
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d62067d4..d9a149a6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -102,6 +102,8 @@ nix = { version = "0.26.4", default-features = false, features = ["term"] }
anyhow = "1.0.75"
indexmap = { version = "2.1.0", features = ["serde"] }
itertools = "0.11.0"
+once_cell = "1.18"
+regex = "1.10.2"
serde = { version = "1.0", features = ["derive"] }
serde_with = "3.4.0"
toml = { version = "0.8.6", features = ["preserve_order"] }