summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcyqsimon <28627918+cyqsimon@users.noreply.github.com>2024-01-19 15:18:48 +0800
committercyqsimon <28627918+cyqsimon@users.noreply.github.com>2024-01-19 15:18:48 +0800
commit230abfd2bc146aaf2c2ea7d2685c97cd22dc0bc2 (patch)
tree207db1f4d8999345b66677d08d01489c41f44801 /Cargo.toml
parentc0f2d6f934754a520df7303ab2e05ff5b39d1b43 (diff)
parent98a2b6bc177050c845f2e12133458826ad1fca72 (diff)
Merge branch 'master' into syntax-mapping-refactor
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f20224e4..3b7f10e6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -46,7 +46,7 @@ ansi_colours = "^1.2"
bincode = "1.0"
console = "0.15.7"
flate2 = "1.0"
-once_cell = "1.18"
+once_cell = "1.19"
thiserror = "1.0"
wild = { version = "2.2", optional = true }
content_inspector = "0.2.4"
@@ -54,7 +54,7 @@ shell-words = { version = "1.1.0", optional = true }
unicode-width = "0.1.11"
globset = "0.4"
serde = { version = "1.0", features = ["derive"] }
-serde_yaml = "0.9"
+serde_yaml = "0.9.28"
semver = "1.0"
path_abs = { version = "0.5", default-features = false }
clircle = "0.4"
@@ -79,12 +79,12 @@ default-features = false
features = ["parsing"]
[dependencies.clap]
-version = "4.4.10"
+version = "4.4.12"
optional = true
features = ["wrap_help", "cargo"]
[target.'cfg(target_os = "macos")'.dependencies]
-home = "0.5.4"
+home = "0.5.9"
plist = "1.5.1"
[dev-dependencies]
@@ -99,7 +99,7 @@ tempfile = "3.8.1"
nix = { version = "0.26.4", default-features = false, features = ["term"] }
[build-dependencies]
-anyhow = "1.0.75"
+anyhow = "1.0.78"
indexmap = { version = "2.1.0", features = ["serde"] }
itertools = "0.11.0"
once_cell = "1.18"
@@ -110,7 +110,7 @@ toml = { version = "0.8.6", features = ["preserve_order"] }
walkdir = "2.4"
[build-dependencies.clap]
-version = "4.4.10"
+version = "4.4.12"
optional = true
features = ["wrap_help", "cargo"]