summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c066b4b..102708e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,11 +21,11 @@ rust-version = "1.74.0"
description = "Display current network utilization by process, connection and remote IP/hostname"
[dependencies]
-anyhow = { version = "1.0.80", features = ["backtrace"] }
-async-trait = "0.1.77"
+anyhow = { version = "1.0.81", features = ["backtrace"] }
+async-trait = "0.1.79"
chrono = "0.4"
clap-verbosity-flag = "2.2.0"
-clap = { version = "4.5.1", features = ["derive"] }
+clap = { version = "4.5.4", features = ["derive"] }
crossterm = "0.27.0"
derivative = "2.2.0"
ipnetwork = "0.20.0"
@@ -36,38 +36,38 @@ pnet = "0.34.0"
pnet_macros_support = "0.34.0"
ratatui = "0.26.1"
resolv-conf = "0.7.0"
-simplelog = "0.12.1"
-thiserror = "1.0.57"
-tokio = { version = "1.36", features = ["rt", "sync"] }
+simplelog = "0.12.2"
+thiserror = "1.0.58"
+tokio = { version = "1.37", features = ["rt", "sync"] }
trust-dns-resolver = "0.23.2"
unicode-width = "0.1.11"
-strum = { version = "0.26.1", features = ["derive"] }
+strum = { version = "0.26.2", features = ["derive"] }
[target.'cfg(target_os = "linux")'.dependencies]
procfs = "0.16.0"
[target.'cfg(any(target_os = "macos", target_os = "freebsd"))'.dependencies]
-regex = "1.10.3"
+regex = "1.10.4"
[target.'cfg(target_os = "windows")'.dependencies]
netstat2 = "0.9.1"
sysinfo = "0.30.5"
[dev-dependencies]
-insta = "1.35.1"
+insta = "1.38.0"
packet-builder = { version = "0.7.0", git = "https://github.com/cyqsimon/packet_builder.git", branch = "patch-update" }
pnet_base = "0.34.0"
-regex = "1.10.3"
+regex = "1.10.4"
rstest = "0.18.2"
[build-dependencies]
-anyhow = "1.0.80"
-clap = { version = "4.5.1", features = ["derive"] }
+anyhow = "1.0.81"
+clap = { version = "4.5.4", features = ["derive"] }
clap-verbosity-flag = "2.2.0"
clap_complete = "4.5.1"
clap_mangen = "0.2.20"
derivative = "2.2.0"
-strum = { version = "0.26.1", features = ["derive"] }
+strum = { version = "0.26.2", features = ["derive"] }
[target.'cfg(target_os = "windows")'.build-dependencies]
http_req = "0.10.2"