summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-08-25 19:02:37 +0800
committercyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-08-25 19:02:37 +0800
commitffbf0cd8aa73ed3db3e9dc01f154eacb5fe1130c (patch)
tree7e20ef11e08466f09044d6423319779d1d70919b /Cargo.toml
parentc780c06807fbed4388eb5636c30a4cc11eeb814c (diff)
Migrate from `failure` to `anyhow`+`thiserror`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 69fd753..5b26017 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,7 +26,6 @@ ipnetwork = "0.20.0"
ratatui = "0.22.0"
crossterm = "0.27.0"
structopt = "0.3"
-failure = "0.1.8"
chrono = "0.4"
regex = "1.9.3"
lazy_static = "1.4.0"
@@ -36,6 +35,8 @@ async-trait = "0.1.73"
unicode-width = "0.1.10"
resolv-conf = "0.7.0"
pnet_macros_support = "0.34.0"
+anyhow = { version = "1.0.75", features = ["backtrace"] }
+thiserror = "1.0.47"
[target.'cfg(target_os="windows")'.dependencies]
netstat2 = "0.9.1"