summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-10-17 16:29:47 +0800
committerGitHub <noreply@github.com>2023-10-17 16:29:47 +0800
commitd9cc84b3732fe9cb0c819b93d67d2a6420f6a065 (patch)
tree4bcf315523d7c27d5e258f0b6beae34a3eaffbfa /Cargo.toml
parent5d2ee96900f18a106d532f8b6ccf56ddf62951d7 (diff)
Partially fix flaky tests (#308)
* Minor code style changes * Disable rendering of timestamps in tests * Update test snapshots * Test everything with insta macros (no more `assert(_eq)?`) - This has the benefit of creating snapshots for everything, allowing for later diffing * Don't use `assert_debug_snapshot` for large string outputs - This makes snapshots more human-inspectable * Code style improvement on two tests - `pause_by_space` - `rearranged_by_tab` * Minor code style improvements
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bf538e4..359e248 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -53,6 +53,7 @@ insta = "1.34.0"
pnet_base = "0.34.0"
packet-builder = { version = "0.7.0", git = "https://github.com/cyqsimon/packet_builder.git", branch = "patch-update" }
rstest = "0.18.2"
+itertools = "0.11.0"
[target.'cfg(target_os="windows")'.build-dependencies]
anyhow = "1.0.75"