summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-09-19 17:39:26 +0800
committercyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-09-19 17:39:26 +0800
commitaccad5a6b05cd8512c952890dbd34b6595d12321 (patch)
tree1b1a9e930366bd11c90b6c1315d783baa057bf77 /Cargo.toml
parent94bbb43faf429f19625cebcf711674fd5b181b2b (diff)
Bump deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 526aae7..27f573f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,11 +23,11 @@ exclude = ["src/tests/*", "demo.gif"]
[dependencies]
pnet = "0.34.0"
ipnetwork = "0.20.0"
-ratatui = "0.22.0"
+ratatui = "0.23.0"
crossterm = "0.27.0"
-clap = { version = "4.4.2", features = ["derive"] }
+clap = { version = "4.4.4", features = ["derive"] }
chrono = "0.4"
-regex = "1.9.3"
+regex = "1.9.5"
tokio = { version = "1.32", features = ["rt", "sync"] }
trust-dns-resolver = "0.23.0"
async-trait = "0.1.73"
@@ -35,11 +35,11 @@ unicode-width = "0.1.10"
resolv-conf = "0.7.0"
pnet_macros_support = "0.34.0"
anyhow = { version = "1.0.75", features = ["backtrace"] }
-thiserror = "1.0.47"
+thiserror = "1.0.48"
[target.'cfg(target_os="windows")'.dependencies]
netstat2 = "0.9.1"
-sysinfo = "0.29.8"
+sysinfo = "0.29.10"
[target.'cfg(target_os="linux")'.dependencies]
procfs = "0.15.1"
@@ -51,5 +51,5 @@ packet-builder = { version = "0.7.0", git = "https://github.com/cyqsimon/packet_
[target.'cfg(target_os="windows")'.build-dependencies]
anyhow = "1.0.75"
-http_req = "0.9.2"
+http_req = "0.9.3"
zip = "0.6.6"