summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFelix Obenhuber <flxo@users.noreply.github.com>2024-04-02 11:39:24 +0200
committerGitHub <noreply@github.com>2024-04-02 17:39:24 +0800
commit9354683481ff3c1a874d25f2a4082f14ec253698 (patch)
treef4fd5dcaaf39ca7c4b9d8bb114d8459208435cbe /Cargo.toml
parent6ef2d569b531faf0c0b9dce2f3b0588ca6645e47 (diff)
Enable Android build (#384)
* Support build for target_os android The target_os `android` is quite similar to `linux` but must be mentioned in the guards explicitly. Tested for target `aarch64-linux-android`. * Add target aarch64-linux-android to ci Use `cross` for building target `aarch64-linux-android`. In the `ci` workflow the matrix branch of `os` `ubuntu-latest` is used because the matrix organization is host os centric instead of target. Releases are build with `cross` for target `aarch64-linux-android`. Install `cross` if needed for a run. At the time of writing the latest release of `cross` can't build binaries for target `aarch64-linux-android` and it's common sense that the latest git tag or `master` shall be used [1]. [1] https://github.com/cross-rs/cross/issues/1222 * Add android related readme section
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 102708e..3f84c5b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -43,7 +43,7 @@ trust-dns-resolver = "0.23.2"
unicode-width = "0.1.11"
strum = { version = "0.26.2", features = ["derive"] }
-[target.'cfg(target_os = "linux")'.dependencies]
+[target.'cfg(any(target_os = "android", target_os = "linux"))'.dependencies]
procfs = "0.16.0"
[target.'cfg(any(target_os = "macos", target_os = "freebsd"))'.dependencies]