summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorremgodow <remgodow@users.noreply.github.com>2020-09-03 18:17:18 +0200
committerGitHub <noreply@github.com>2020-09-03 18:17:18 +0200
commit1db74c81ebf20847b90d585b86ed1314496c7aec (patch)
treea7207627c5eb946aa6838490f162a7a90825357e /Cargo.toml
parentb275ee61e11c3404c84868e85b1a52b8dd231d03 (diff)
feat(infra): replace termion with Windows compatible crossterm (#179)
* Replace termion backend with crossterm, which works on Windows as well. * Remove tui default-features (termion), update unit tests for crossterm. * Fix formatting.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 97bcfa6..11559a3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,8 +21,8 @@ exclude = ["src/tests/*", "demo.gif"]
[dependencies]
pnet = "0.26.0"
ipnetwork = "0.16.0"
-tui = "0.5"
-termion = "1.5"
+tui = { version = "0.5", default-features = false, features = ["crossterm"]}
+crossterm = "0.17.7"
structopt = "0.3"
signal-hook = "0.1.10"
failure = "0.1.6"