summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorcyqsimon <28627918+cyqsimon@users.noreply.github.com>2023-11-02 14:00:58 +0800
committerGitHub <noreply@github.com>2023-11-02 14:00:58 +0800
commit16a6f9eec6079a08d31159e296f6009034bd533c (patch)
treeb962fadd053b67a5e0155fc1410631a15050b7cb /Cargo.toml
parentcf9b9f063420b153225d4e2ff49e22a2f97dbddf (diff)
Display bandwidth in different unit families (#328)
* Allow selecting unit families - Supported units are {binary,SI}-{bytes,bits} * Fix typo * Better error msg in the unreachable case * - I can't believe I did this. Frankly, terrible. * Add unit test * Add peta&pebi units to be absolutely future-proof * Minor code style improvement
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index feb17b8..fd2307b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -41,6 +41,7 @@ thiserror = "1.0.50"
tokio = { version = "1.33", features = ["rt", "sync"] }
trust-dns-resolver = "0.23.2"
unicode-width = "0.1.11"
+strum = { version = "0.25.0", features = ["derive"] }
[target.'cfg(target_os = "linux")'.dependencies]
procfs = "0.16.0"