summaryrefslogtreecommitdiffstats
path: root/atuin-server/Cargo.toml
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-05-16 23:14:04 +0200
committerGitHub <noreply@github.com>2022-05-16 22:14:04 +0100
commitf3407710128928dcb3fa9a83c206631987bf395a (patch)
tree1e674f1e2b08637d1105e600c8466a080bfa2864 /atuin-server/Cargo.toml
parentab294cde3460665dfa78514f0e20da00984e3943 (diff)
Cleanup dependencies – disable unnecessary or unused features (#407)
* Disable unnecessary features of config crate, keep only toml The atuin documentation only mentions the TOML format for configuration files, but the config crate supports many other formats by default, which increases the binary size by about 300 kiB. * Disable unused features of cli-table crate This doesn't seem to have noticeable effect on the binary size, but disabling them cleans up the dependency tree a bit.
Diffstat (limited to 'atuin-server/Cargo.toml')
-rw-r--r--atuin-server/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/atuin-server/Cargo.toml b/atuin-server/Cargo.toml
index 73639d0c..a565d897 100644
--- a/atuin-server/Cargo.toml
+++ b/atuin-server/Cargo.toml
@@ -16,7 +16,7 @@ chrono = { version = "0.4", features = ["serde"] }
eyre = "0.6"
uuid = { version = "1.0", features = ["v4"] }
whoami = "1.1.2"
-config = "0.13"
+config = { version = "0.13", default-features = false, features = ["toml"] }
serde = { version = "1.0.137", features = ["derive"] }
serde_json = "1.0.81"
sodiumoxide = "0.2.6"