summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
authorMag Mell <sakiiily@aosc.io>2024-01-26 17:45:42 +0800
committerGitHub <noreply@github.com>2024-01-26 09:45:42 +0000
commitd21de3cd252d80bf54a6d0b175122048b8af85fd (patch)
treeeae5aa9d0bef0f1ba7a335860e015201d608c264 /atuin-client/Cargo.toml
parent400e1ba23d4b26ebb23b5c41db4983920ecaf9aa (diff)
chore: add feature to allow always disable check update (#1628)
* chore: add feature to allow always disable check update In the packaging rules of some distributions, the software's self-update check needs to be permanently turned off This commit will make it easier for these users to * fix: formatting --------- Co-authored-by: Ellie Huxtable <ellie@elliehuxtable.com>
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
index cbb8d016..e224ad83 100644
--- a/atuin-client/Cargo.toml
+++ b/atuin-client/Cargo.toml
@@ -15,6 +15,7 @@ repository = { workspace = true }
[features]
default = ["sync"]
sync = ["urlencoding", "reqwest", "sha2", "hex"]
+check-update = []
[dependencies]
atuin-common = { path = "../atuin-common", version = "17.2.1" }