summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <ellie@elliehuxtable.com>2024-04-18 16:41:28 +0100
committerGitHub <noreply@github.com>2024-04-18 16:41:28 +0100
commit95cc472037fcb3207b510e67f1a44af4e2a2cae9 (patch)
treefc1d3e71d8e0bdb806370e4144fd6f373bcc9c5e /atuin-client/Cargo.toml
parent176eae02f7f855ef40a4461caca61d530486113f (diff)
chore: move crates into crates/ dir (#1958)
I'd like to tidy up the root a little, and it's nice to have all the rust crates in one place
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml73
1 files changed, 0 insertions, 73 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
deleted file mode 100644
index c8ca74ae..00000000
--- a/atuin-client/Cargo.toml
+++ /dev/null
@@ -1,73 +0,0 @@
-[package]
-name = "atuin-client"
-edition = "2021"
-description = "client library for atuin"
-
-rust-version = { workspace = true }
-version = { workspace = true }
-authors = { workspace = true }
-license = { workspace = true }
-homepage = { workspace = true }
-repository = { workspace = true }
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[features]
-default = ["sync"]
-sync = ["urlencoding", "reqwest", "sha2", "hex"]
-check-update = []
-
-[dependencies]
-atuin-common = { path = "../atuin-common", version = "18.2.0" }
-
-log = { workspace = true }
-base64 = { workspace = true }
-time = { workspace = true, features = ["macros", "formatting"] }
-clap = { workspace = true }
-eyre = { workspace = true }
-directories = { workspace = true }
-uuid = { workspace = true }
-whoami = { workspace = true }
-interim = { workspace = true }
-config = { workspace = true }
-serde = { workspace = true }
-serde_json = { workspace = true }
-parse_duration = "2.1.1"
-async-trait = { workspace = true }
-itertools = { workspace = true }
-rand = { workspace = true }
-shellexpand = "3"
-sqlx = { workspace = true, features = ["sqlite", "regexp"] }
-minspan = "0.1.1"
-regex = "1.10.4"
-serde_regex = "1.1.0"
-fs-err = { workspace = true }
-sql-builder = "3"
-memchr = "2.5"
-rmp = { version = "0.8.11" }
-typed-builder = { workspace = true }
-tokio = { workspace = true }
-semver = { workspace = true }
-thiserror = { workspace = true }
-futures = "0.3"
-crypto_secretbox = "0.1.1"
-generic-array = { version = "0.14", features = ["serde"] }
-serde_with = "3.5.1"
-
-# encryption
-rusty_paseto = { version = "0.6.0", default-features = false }
-rusty_paserk = { version = "0.3.0", default-features = false, features = [
- "v4",
- "serde",
-] }
-
-# sync
-urlencoding = { version = "2.1.0", optional = true }
-reqwest = { workspace = true, optional = true }
-hex = { version = "0.4", optional = true }
-sha2 = { version = "0.10", optional = true }
-indicatif = "0.17.7"
-
-[dev-dependencies]
-tokio = { version = "1", features = ["full"] }
-pretty_assertions = { workspace = true }