summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <ellie@elliehuxtable.com>2024-02-08 13:34:41 +0000
committerGitHub <noreply@github.com>2024-02-08 13:34:41 +0000
commit8460210202af4e48ea55c997bf2739a6f0570e4a (patch)
treeb65b7ec55da171d9246be0d2ef77a7e39ecf45cb /atuin-client/Cargo.toml
parent199365310248eecedf8fbad579fc0cdc2e47bbe7 (diff)
feat: add progress bars to sync and store init (#1684)
Replace lots of logging with some progress bars. This looks much nicer I'd like to move it out of the atuin-client crate and into the atuin crate. But first, I want to decouple a lot of the record moving, so it can wait until that's done.
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
index 991c594e..9d1e8768 100644
--- a/atuin-client/Cargo.toml
+++ b/atuin-client/Cargo.toml
@@ -67,6 +67,7 @@ urlencoding = { version = "2.1.0", optional = true }
reqwest = { workspace = true, optional = true }
hex = { version = "0.4", optional = true }
sha2 = { version = "0.10", optional = true }
+indicatif = "0.17.7"
[dev-dependencies]
tokio = { version = "1", features = ["full"] }