summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
authorJ. Emiliano Deustua <edeustua@gmail.com>2023-06-13 02:43:06 -0500
committerGitHub <noreply@github.com>2023-06-13 07:43:06 +0000
commit79f7b1d81c182bfbcc8298963886390658dda71b (patch)
tree8638d9aae39bcb93e8f3120b438f3b40d6e199c4 /atuin-client/Cargo.toml
parentb231b82bdd0a52f8fb38350ba1cd5ea285a9127a (diff)
Fix `--delete-it-all` and `--delete` commands (#913)
* Add `delete_at` is null condition during search Since entries are searched everytime a delete process ends, the --delete-it-all command will enter an infinite loop if searching the whole history. * Remove command blanking Command blanking may violate the `unique(timestamp, cwd, command)` condition. * Overwrite command with random string when deleting * Add rand dependency to client crate --------- Co-authored-by: Ellie Huxtable <ellie@elliehuxtable.com>
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
index 770d7741..42e3cf6b 100644
--- a/atuin-client/Cargo.toml
+++ b/atuin-client/Cargo.toml
@@ -41,6 +41,7 @@ serde_json = { workspace = true }
parse_duration = "2.1.1"
async-trait = { workspace = true }
itertools = { workspace = true }
+rand = { workspace = true }
shellexpand = "2"
sqlx = { workspace = true, features = ["sqlite"] }
minspan = "0.1.1"