summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <e@elm.sh>2021-04-25 18:21:52 +0100
committerGitHub <noreply@github.com>2021-04-25 17:21:52 +0000
commit156893d774b4da5b541fdbb08428f9ec392949a0 (patch)
tree9185d94384aa62eb6eb099ddc4ca9408df6f90d1 /atuin-client/Cargo.toml
parent4210e8de5a29eb389b753adf8df47d2c449a2eeb (diff)
Update docs, unify on SQLx, bugfixes (#40)
* Begin moving to sqlx for local too * Stupid scanners should just have a nice cup of tea Random internet shit searching for /.env or whatever * Remove diesel and rusqlite fully
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
index 4d3e9130..bd09ca42 100644
--- a/atuin-client/Cargo.toml
+++ b/atuin-client/Cargo.toml
@@ -37,6 +37,6 @@ tokio = { version = "1", features = ["full"] }
async-trait = "0.1.49"
urlencoding = "1.1.1"
humantime = "2.1.0"
-rusqlite= { version = "0.25", features = ["bundled"] }
itertools = "0.10.0"
shellexpand = "2"
+sqlx = { version = "0.5", features = [ "runtime-tokio-rustls", "uuid", "chrono", "sqlite" ] }