summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <e@elm.sh>2020-10-05 00:59:28 +0100
committerEllie Huxtable <e@elm.sh>2020-10-05 00:59:28 +0100
commit27b9a9430518c071a2a7de7f46dfd8aac3cead80 (patch)
tree0551a4979606d7bf351149df10cf08f47dc9e665 /Cargo.toml
Initial commit
Currently writing shell history to a sqlite db :) Could do with: 1) store exit code 2) store duration 3) tidy up main 4) ...remote stuff
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 00000000..169a2c96
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "shync"
+version = "0.1.0"
+authors = ["Ellie Huxtable <e@elm.sh>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+log = "0.4"
+pretty_env_logger = "0.4"
+clap = "2.33.3"
+chrono = "0.4.19"
+eyre = "0.6.1"
+shellexpand = "2.0.0"
+rusqlite = "0.24.0"