summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGaute Hope <eg@gaute.vetsj.com>2017-11-14 09:18:45 +0100
committerGaute Hope <eg@gaute.vetsj.com>2017-11-14 13:52:57 +0100
commit81691550419a1b5f82383da899cdd5c2da0d24e1 (patch)
treefde32a830a7d99c98ba0c48a9711b74f52fe8ee2 /CMakeLists.txt
parentf469b4128c778c34ad6f38e0f443ed995782eac8 (diff)
cmake: always export compile_commands
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72fa8fb..6a3157c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,8 @@ cmake_minimum_required (VERSION 3.9)
set (CMAKE_CONFIGURATION_TYPES Debug Release CACHE TYPE INTERNAL FORCE)
message (STATUS "Available config types: ${CMAKE_CONFIGURATION_TYPES}")
+set (CMAKE_EXPORT_COMPILE_COMMANDS ON)
+
##
# make sure the user deliberately selects a build type
#